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1 Introduction 
Getting a book out into the world can be an intimidating task. You may have heard of the traditional 

publishing route: drafting and revising your manuscript; finding an agent to represent you and an editor 

to work with; negotiating a deal with a publishing house and selling your book. Unfortunately, the route 

has many drawbacks: 

• Slow process – nine months to two years can pass between signing your book contract and 

actually having your book in publication 

• Deadline stress –you have to meet deadlines and might experience author burnout as a result 

• Loss of rights – you surrender some creative control over your work 

• Less royalties – you might not earn as much due to both lower rates and infrequent pay days 

• Legalese – you have to navigate complex publisher contracts 

• Rejection – you can be turned down by many publishing houses and might not be able to 

publish the book you want 

Luckily, Kindle Direct Publishing (KDP) allows you to work around all these drawbacks:  

• Fast process – publication is instantaneous 

• Minimal deadline stress – much like freelancing, you set your own schedule 

• Maintenance of rights - you keep creative control over your work and own all the rights 

• More royalties - you earn more due to both higher rates and more frequent pay days 

• Lack of legalese - you don’t have to navigate complex publisher contracts 

• Lack of rejection – you can publish what you want; every book can get published 

Moreover, the benefits of Kindle go beyond simply addressing the drawbacks of traditional publishing 

houses. Additional benefits include: 

• Amazon is the world’s largest bookstore (responsible for selling over 70% of books) 

• Algorithms help potential readers find your book (helpful to indie authors) 

• You’re not limited to selling eBooks (you can print books from your account) 

• You have a variety of marketing tools at your disposal (not only various in-house programs such 

as sample chapters, but also third-party services if necessary) 

Kindle has also opened up the publishing arena, providing greater opportunity for people of different 

backgrounds. No matter who you are, Kindle can get your book out into the world. Consider the 

following new authors who have sold millions of eBooks on the Amazon Kindle platform:  

• Mike Omer, a 39-year-old Israeli computer engineer, was able to quit his job and go full-time as 

a self-published author off the sales of his first eBook Spider’s Web and its sequels. He makes 

more money now than he did as a computer engineer. 

• Nandini Kumar has been writing since she was 16 and now publishes stories on Kindle in both 

English and Hindi. Her book Neeli won the Kindle Direct Publishing Award. 

• Sudha Nair took a break from her eight-year software engineer career upon having children. 

After a stint as a technical writer, she wrote a novel called The Wedding Tamasha but didn’t 

hear back from traditional publishers. So, she self-published on Kindle and not only gained a 

devoted reader base, but also won Kindle’s Pen-to-Publish Contest Award. 
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Naturally, these success stories aren’t a guarantee. Many factors go into the making of a smash hit, 

including the unpredictable factor of luck. However, you can ensure that you put yourself in the best 

position to reach such levels of success. You can study your genre. You can follow market trends. And of 

course, you can use this guide to learn how to use the various features of Kindle and familiarize yourself 

with the eBook creation process. This guide will assume you already have the content of your 

manuscript written, and will focus on the technical side of the process. 

Let’s begin! 
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2 Selecting a Title  
Now that you’ve written your manuscript, you need a title. Your title is the first thing your readers see. 

Therefore, your title must hook your target audience and hint at your book’s plot and tone. A good title 

can be the difference between your reader choosing to give your book a chance or passing it up 

altogether. 

Follow the steps below to select a title for your eBook. 
1. Ensure that your title: 

a. is the ideal length by shortening it to two to five words. 

b. is genre-appropriate by going to websites like Amazon or Goodreads, searching for the 

genre you want to write, and noting patterns or trends in title construction. 

c. has not been used already by searching up your title on Amazon. 

 

Figure 1. Sample Goodreads Search 
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Figure 2. Sample Amazon Search 
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3 Importing Your Manuscript Using Kindle Create 

3.1 Downloading and Installing Kindle Create 
Now that you’ve written your manuscript and selected a title, you can create your eBook. Before you 

create an eBook, however, you first need to download and install eBook creation software. Luckily, you 

won’t have to look very far to find the software you need. Kindle offers in-house software in Kindle 

Create, a free and beginner-friendly option. 

NOTE: You can use other eBook creation software, of course. For the purposes of this guide, we will use 

Kindle Create. 

You will need: 

• RAM 

o Minimum – 4 GB 

o Recommended – 8 GB 

• Processor 

o Minimum – 1.2 GHz 

o Recommended – 2 GHz 

• Operating system 

o If Windows – 8.1 (64-bit) or later for PC (64-bit) running on Intel or AMD CPUs 

o If macOS – 10.14 (64-bit) or later for Mac 

Follow the steps below to download and install Kindle Create. 
1. Go to the following link:  

https://kdp.amazon.com/en_US/help/topic/GUGQ4WDZ92F733GC#download.  

2. Locate the Download Kindle Create heading. 

 

Figure 3. Kindle Create Download 

3. Click the Download button that matches the operating system you’re running. A file called 

KindleCreateInstaller.exe will appear in your downloads. 

https://kdp.amazon.com/en_US/help/topic/GUGQ4WDZ92F733GC#download
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Figure 4. Kindle Create Installer Executable File 

4. Click KindleCreateInstaller.exe to open the file. The Kindle Create Installation wizard opens to 

the License Agreement dialog. 

 

Figure 5. Kindle Create License Agreement 

5. Once you have read the License Agreement, click I Agree to accept. The Choose Install Location 

dialog opens. 

 

Figure 6. Kindle Create Choose Install Location 

6. Once you have chosen a folder in which to install Kindle Create, click Install. The wizard begins 

installing Kindle Create. 
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Figure 7. Kindle Create Installing 

1. Once installation is complete, the Completing Kindle Create Setup dialog opens. Click Finish to 

close the wizard. 

2.  

Figure 8. Completing Kindle Create Setup 

3.2 Preparing Your Manuscript for Import 
Now that you’ve written your manuscript, selected your title, and installed Kindle Create, you can 

import your manuscript into Kindle Create. Before you import, however, you first need to make sure 

your manuscript follows Kindle Create’s formatting guidelines. 
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You will need: 

• Microsoft Word 

• Your manuscript 

Follow the steps below to prepare your manuscript for import. 
1. Open your manuscript in Microsoft Word. 

2. Remove or modify the following elements from your manuscript as needed: 

o Headers, footers, and page numbers (eBooks are reflowable, adaptable to different 

layouts) 

o Tab-spaced paragraphs, double-spaced lines, and hard returns 

o Cover image (remove from the manuscript but save it elsewhere for later) 

o Track changes (a feature in Word that allows you to see changes made – set to Off) 

o Drop caps (the oversized capital letters or words at the start of a chapter) 

o Shapes and text boxes 

3. Apply the Heading 1 style to your chapter titles. Center your titles. 

 

Figure 9. Heading 1 Style 

4. Insert page breaks to let Kindle Create know where to separate your content. 

 

Figure 10. Page Break 

5. Include the following elements in your manuscript as needed: 

a. Footnotes 

b. Hyperlinks (links to webpages or other external references) 

c. Images 
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d. Front and back matter (the information before and after your manuscript’s actual 

content such as title pages or appendices) 

3.3 Importing Your Manuscript 
Now that your manuscript meets Kindle Create’s formatting guidelines, you’re ready to import. 

You will need: 
• Kindle Create 

• Your manuscript 

Follow the steps below to import your manuscript. 
1. Open Kindle Create. 

 

Figure 11. Kindle Create Start 

2. Click Create New>Choose. You can also click File>New Project. The Choose File dialog opens. 
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Figure 12. Kindle Create Choose File 

3. Click Reflowable. 

4. Click your book’s language in the Document Language dropdown. 

 

Figure 13. Kindle Create Document Language 

5. Click Choose File. The Import from File dialog opens. 
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Figure 14. Kindle Create Import from File 

6. Locate your manuscript on your local hard drive, click your manuscript, and click Open. Kindle 

Create begins importing and converting your manuscript to an eBook. 

 

Figure 15. Kindle Create Importing and Converting Your Document 

7. Once import and conversion are complete, the Import Successful dialog opens. Click Continue. 
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Figure 16. Kindle Create Import Successful 

8. The Automatic Chapter Titles dialog opens. Click Get Started. 

 

Figure 17. Kindle Create Automatic Chapter Titles 

9. The Suggested Chapter Titles dialog opens. Uncheck any non-chapter headings. Click Accept 

Selected. 
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Figure 18. Kindle Create Suggested Chapter Titles 

10. Click File>Save Project. The Save Your Project dialog opens. 

 

Figure 19. Kindle Create Save Your Project 

11. Accept or change the file location and name. Click Save.  
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4 Preparing Your eBook for Publishing 

4.1 Creating a Table of Contents (TOC) 
Now that you’ve created your eBook and accepted your selected chapter titles, you can create a TOC. A 

TOC is a must for any eBook, helping your readers navigate between chapters.  

You will need: 
• Kindle Create 

• Your eBook 

Follow the steps below to create a TOC. 
1. Open your eBook in Kindle Create. 

2. Locate Contents. 

 

Figure 20. Kindle Create Contents 

3. Click your first chapter. 
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Figure 21. Kindle Create First Chapter Clicked 

4. Click Insert>Table of Contents. 

 

Figure 22. Kindle Create Insert Table of Contents 

5. Click OK. 
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4.2 Styling Your eBook 
Now that you’ve created your eBook and created a TOC, you can update the look and feel of your 

content. Luckily, Kindle has prebuilt themes that streamline the process for you. 

You will need: 
• Kindle Create 

• Your eBook 

Follow the steps below to add a theme. 
1. Open your eBook in Kindle Create. 

2. Click Theme. 

 

Figure 23. Kindle Create Theme Icon 

1. The Theme dialog opens. Click your desired theme from the options. 

 

Figure 24. Kindle Create Theme 

2. Click Select. 

4.3 Previewing Your eBook 
Now that you’ve styled your eBook, you can preview it to see how your content will look on different 

devices. 
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You will need: 
• Kindle Create 

• Your eBook 

Follow the steps below to preview your eBook. 
1. Open your eBook in Kindle Create. 

2. Click Preview. 

 

Figure 25. Kindle Create Preview Icon 

3. The Preview dialog opens. Check for any changes you need to make. 

 

Figure 26. Kindle Create Preview 

4.4 Generating a Publishable File (.kpf file) 
Now that you’ve previewed your eBook, you can generate a .kpf file for Kindle. 

You will need: 
• Kindle Create 
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• Your eBook 

Follow the steps below to preview your eBook. 
1. Open your eBook in Kindle Create. 

2. Click Generate. 

 

Figure 27. Kindle Create Generate Icon 

3. The Save File for Publication dialog opens. Accept or change the file location and name. 

 

Figure 28. Kindle Create Save File for Publication 

4. Click Save. 

5. Click OK. 
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5 Publishing to Kindle Direct Publishing (KDP)  

5.1 Creating a Kindle Direct Publishing (KDP) Account 
Now that you’ve generated a .kpf file, you’re ready to upload to Kindle. Before you upload, however, 

you first need to create a KDP account. 

You will need: 
• Your Amazon account or e-mail address 

• Your mobile number 

• Your mobile device 

• Your address 

• Your bank information 

• Your tax information 

Follow the steps below to create a KDP account. 
1. Go to the following link: 

https://kdp.amazon.com/en_US/ 

2. Locate the Sign in with Your Amazon Account heading. 

 

Figure 29. KDP Sign In 

3. Click Sign In if you have an existing Amazon account. Otherwise, click Sign Up. 

https://kdp.amazon.com/en_US/
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4. Once you have completed the Sign In or Sign Up, you are taken to the Terms and Conditions. 

Click Agree.

 

Figure 30. KDP Terms and Conditions 

5. Locate the Your Account Information Is Incomplete warning. Click Update Now. 

 

Figure 31. KDP Incomplete Account Information 

6. You are taken to the Two-Step Verification. Enter the phone number where you would like to 

receive the One Time Password (OTP) and click Send OTP. 

 

Figure 32. KDP Two-Step Verification 
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7. Enter the OTP. 

8. Once you have completed the Two-Step Verification, you are taken to My Account. Locate the 

Which Country/Region Do You Live In? heading.  

9. Select your country or region from the Country or Region dropdown and enter your address. 

10. Locate the Getting Paid heading. 

11. Enter your bank information. 

12. Locate the Tax Information heading. 

13. Enter your tax information. 

14. Click Finished. 

5.2 Uploading Your Publishable File (.kpf) to Kindle Direct Publishing (KDP) 
Now that you’ve generated a .kpf file and set up a KDP account, you can upload your .kpf file to KDP. 

You will need: 
• Your .kpf file 

Follow the steps below to upload your .kpf file to KDP. 
1. Go to your KDP account. 

2. Click Bookshelf. 

3. Locate the Create a New Title heading. 

 

Figure 33. KDP Create a New Title 

4. Click Kindle eBook. 

5. You are taken to a page called Edit eBook Details. Enter your eBook details. 

6. Click Save and Continue. 

7. You are taken to a page called Edit eBook Content. Under the Manuscript heading click Upload 

eBook Manuscript. 
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Figure 34. KDP Manuscript 

8. Locate your .kpf file on your local hard drive, click your .kpf file, and click Open. 

9. Under the Kindle eBook Cover heading, click Launch Cover Creator or Upload a Cover You 

Already Have. 

 

Figure 35. KDP Cover 

10. Locate your cover image file on your local hard drive, click your cover image file, and click Open. 

11. Click Save and Continue. 

12. You are taken to a page called edit eBook Pricing. Enter your desired pricing information. 

13. Click Publish Your Kindle eBook. Your book can take up to 72 hours to be available for purchase 

on Amazon. 

14. You’ve done it! You’re a published author! 
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Glossary 
This is a list of the terms, acronyms, and abbreviations used in this document. 

Table 2. Terms, Acronyms, and Abbreviations 

CPU computer 

eBook electronic book 

GB gigabyte 

GHz gigahertz 

KDP Kindle Direct Publishing 

OTP one time password 

PC personal computer 

RAM random access memory 

reflowable adaptable to different layouts 

TOC table of contents 
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